T-Home (VDSL) unter Debian Linux einrichten (vlan 7 und 8)

Wie gestern angekündigt [1] bringe ich heute ein kleines Update bezüglich T-Home’s IPTV. Aus welchen Gründen auch immer – evtl. um besser skalieren zu können – hat die Telekom zusammen mit T-Online das Fernsehen auf die VLAN ID8 gelegt. Das bedeutet, dass man mit der bisher verwendeten Einwahlmethode so kein IPTV mehr empfangen kann. Das ist aber alles halb so schlimm, denn die Lösung war einfacher als erwartet. Zuerst hatte ich gedacht, dass ich eine zweite PPP-Verbindung aufbauen muss, das hatte leider nicht funktioniert.

Also Grundlage für diese Einrichtung ist, dass ihr Euch einwählen könnt. Das habe ich schon vor ein paar Monaten hier im Blog dokumentiert: http://cmmx.de/2007/04/15/t-home-iptv-ohne-speedport-unter-linux-vdsl/ – Eventuell werde ich demnächst auch mein Wiki dazu updaten. Wenn Ihr online seid, braucht ihr jetzt nur ein paar kleine Zeilen ausführen und eine Datei vom IGMP Proxy bearbeiten:

# vconfig add eth1 8
# dhclient3 eth1.8

In der /etc/igmpproxy.conf nun noch eine Zeile geändert:

#phyint ppp0 upstream  ratelimit 0  threshold 1 (Diese Zeile wird nicht mehr benötigt)
phyint eth1.8 upstream  ratelimit 0  threshold 1

Den IGMP Proxy neu gestartet und schon funktioniert es wieder. Das ganze kann man nun noch unter /etc/network/interfaces (Debian) unterbringen, oder in irgendwelchen ip-up.d Skripts unterbringen. Wenn wer noch Anregungen oder Verbesserungswünsche hat, bitte melden. Ach noch was: Laut Telekom sollte das Fernsehen jetzt nicht mehr getrennt werden. Deshalb glaube ich, dass meine Lösung suboptimal ist, da beim Trennen vom ppp/pppoe auch die eth1.8 Schnittstelle vom Saft abgetrennt wird. Die IP bleibt zwar nach Reconnect erhalten, aber das Fernsehbild ist für wenige Sekunden aus. Das lässt mich vermuten, dass es noch eine bessere Lösung gibt.

Der Vorteil für den Kunden bei dieser Umstellung ist mir unklar. Außer evtl., dass eine Trennung das IPTV nicht mehr beeinflussen soll. Bisher habe ich aber keine anderen Beobachtungen gemacht. Für Statistiker ist es nett, weil IPTV Traffic und Internet Traffic jetzt getrennt ist. Bei Fragen im T-Home Forum vorbei schauen: http://thome.freakempire.de

[1] http://cmmx.de/2009/02/16/t-home-iptv-vlan-8-bei-t-online/

28 Gedanken zu „T-Home (VDSL) unter Debian Linux einrichten (vlan 7 und 8)

  1. Pingback: Claus’ Blog » Blog Archive » T-Home IPTV ohne Speedport unter Linux (VDSL)

  2. Wie und vorallem wann bekommt man mit, wenn die Umstellung erfolgt? Ich habe hier einen Minirouter laufen, der leider an einer sehr unzugänglichen Stelle steht bzw. liegt und den ich erst mühsam ausgraben muss. Telnet oder ssh ist nicht installiert, ich muss also für was ändern ran.

  3. Soll ja auch erst Ende 2009 fertig sein.

    Claus: Koenntest du mir irgendwo 1-2 Minuten an log des igmpproxy hochladen?
    Ich versuche das Ganze gerade auf meinem WRT54GL mit Tomato-Firmware umzusetzen und das gemipste Kompilat laeuft zwar und spuckt auch haufenweise kram aus, aber der Mediareceiver gibt nach der Unicast-Phase nichts von sich. Wuerde gerne mal sehen, wie das funktionierend aussieht.

  4. Übersichtliche Anleitung , jedoch eine Frage:
    -muß man alle Interfaces , die nicht gebraucht sind auf disabled setzen ?
    – wenn ich eth1.8 also upstream angeben , dann geht der igmpproxy mit
    There must be at least 2 Vif’s where one is upstream.

    was kann das sein ?

    Marcel

  5. Auf die Schnelle kann ich dir das nicht sagen. Aber ich meine mich zu erinnern, dass alle nicht für IPTV genutzten Schnittstellen auf „disabled“ gesetzt werden müssen.

  6. Hi Claus,

    habe das gleiche Problem, wie Marcel. Bekomme immer wieder „There must be at least 2 Vif’s where one is upstream.“ Wie sieht die genaue igmpproxy.conf nun aus. Bislang lief alles ohne Probleme mit VLAN ID7. Seit heute ist bei mir anscheinend umgestellt worden.

  7. Hallo ,

    ich wieder. Nach der VLAN ID 7 auf 8 Umstellung habe ich das Problem, dass alle 2-3 Minuten das Bild und der Ton stehen bleiben, dann nach etwa 1-2 Minuten wieder weiter laufen. Hast Du das schon einmal gehört?

    Humph

  8. Hallo Humph_rey,

    zum einen, erzähl‘ mir doch bitte, was du wegen der Fehlermeldung dann unternommen hast.
    Und das Problem habe ich so noch nicht gehört. Vielleicht schaust mal in meinem Forum zu T-Home vorbei und schilderst das Problem detailliert. Da ist es einfacher dir zu helfen.
    (PS: Bei mir ist damals ab und zu der Ton ausgefallen. Und ging Minuten lang dann nicht mehr. Hat sich aber von allein behoben.)

  9. Hallo Claus,

    bei mir war die Fehlermeldung „There must be at least 2 Vif’s where one is upstream“ weg, nachdem ich das VLAN8 richtig eingerichtet hatte und per dhclient3 eine IP bekam.

  10. Hab die vlan 8 Umstellung seit einer Woche hier, System ist Suse 11.0 64bit. Läuft auch beinahe, außer dass nach immer drei Minuten Bild und Ton im Media Receiver stehenbleiben und nach einer halben Minute weiterlaufen. […]

  11. Hallo Jonas,
    die Kommentar Funktion vom Blog ist wirklich nicht dazu geeignet,
    Probleme dieses Formats zu lösen.
    Bitte benutz mein Forum. http://thome.freakempire.de
    Ich bin derzeit sehr im Stress. Kann dir momentan aus zeitlichen Gründen
    nicht helfen. Vielleicht Ende der Woche.

    Und wenn du Hilfe erwartest, dann geb eine korrekte Email Adresse an. Deine existiert nicht.

  12. Ich habe gerade den Artikel http://de.wikipedia.org/wiki/T-Home_Entertain gelesen, wenn ich das richtig interpretiere braucht es für einen unterbrechungsfreien Fernsehzugang nicht viel. Probieren kann ich es zwar mangels Anschlusses nicht, meines Erachtens dürfen die beiden Zeilen

    # vconfig add eth1 8
    # dhclient3 eth1.8

    zwar in der /etc/networks/interfaces oder in den ip-up.d Skripten auftauchen, dort aber in der Konfiguration des eth1-Interfaces, keinesfalls bei ppp0. Sie werden also nur einmalig beim Hochfahren oder Runlevelwechsel ausgeführt. Nur die PPPoE Strecke auf VLAN-ID 7 wird wie gehabt einmal pro Tag getrennt, eth1.8 bleibt die ganze Zeit unberührt (also auch kein ifconfig eth1 down oder ähnliches bei der ppp0-Konfiguration).

    Auf jeden Fall vielen Dank für die Informationen, auch wenn ich im August den VDSL-Anschluss ohne Fernsehen bekommen werde ist jede Information nützlich für mich.

  13. Hallo, erstmal Danke an Claus für Deine „Pionierarbeit“. Für die Gentoo Nutzer unter uns eine Anmerkung: Ich hatte vorher gar keinen DHCP-Client am Start und habe kurzerhand das Paket „dhcp“ gemergt. Damit geht es nicht! Seit gestern Nacht ist auch in Stuttgart IPTV auf VLAN8 umgestellt. Hat ne Weile gedauert bis ich da durchgestiegen bin, aber mit „dhcpcd“ funktioniert es hingegen. Ist soweit ich jetzt weiß auch der Standard für die meisten Distris… Hoffe etwas hilfreiches beigetragen zu haben.

    Hier noch meine /etc/conf.d/net:
    config_eth0=(„null“)
    vlans_eth0=“7 8″
    config_eth0_7=(„null“)
    config_eth0_8=(„dhcp“)
    RC_NEED_ppp0=“net.eth0″
    config_ppp0=(„ppp“)
    link_ppp0=“eth0.7″
    plugins_ppp0=(„pppoe“)
    pppd_ppp0=(
    „defaultroute“
    „usepeerdns“)
    username_ppp0=“xxxxxxxxxx@t-online.de“
    password_ppp0=“xxxxxxxxxx“

    Viele Grüße

  14. vlan Interfaces habe ich bisher immer so eingetragen (der fehlende Punkt beim add ist korrekt, beim rem gehoert er dazu)

    auto eth1.8
    iface eth1.8 inet dhcp
    pre-up /sbin/vconfig add eth1 8
    post-down /sbin/vconfig rem eth1.8

  15. Hi,

    Tausend Dank für den Hinweis auf das VLAN 8, ich hatte schon die Hasskappe aufgesetzt nachdem das Teil nach 10 sekunden stehen blieb ………

    Welchen igmpproxy nimmst Du eigentlich ? Ich habe hier 0.1 Beta2 – was mich stört ist das er das syslog so vollseucht. Ich sah heute bei sourceforge das es mittlerweilen eine „echte“ 0.1 version gibt – schon ma getestet ??

    thx again

    Klaus

  16. Ja ich habe es eben getestet. Finger weg!

    Die einzige Version, die funktioniert, ist die „alte“ von 2005. War jetzt ein Geflicke, bis ich wieder alles zum Laufen bekommen habe.

  17. Hi Claus,

    das mit der alten igmpproxy-Version kann ich nicht bestätigen. Hab in den letzten Tagen meinen Homerouter neu gebaut und dabei die Version 0.1 aus dem gentoo-portage installiert… funktioniert problemlos.
    Allerdings bin ich wieder in den selben Irrtum mit dem dhcp-Client gerannt. Manchmal muss man Fehler 2 mal machen… *kopfschüttel*

    Gruß
    euer Spamferkel

    P.S.: Im T-online Forum gibts einen Beitrag der mir erst wirkliche Klarheit über dieses igmp-Zeugs im Zusammenhang mit meinem Netgear GS108T verschafft hat. Sehr empfehlenswert: http://foren.t-online.de/foren/read.php?552,3311050,fid=65435c7

  18. Was für ein Spass….

    Heute hatte ich auch das „IPTV-Vergnügen“.

    Wollte nur kurz anmerken, dass die „Version von 2009 / 0-1 (final / nonbeta) ebenfalls prima funktioniert. Das Problem liegt an der falschen Reihenfolge der Anweisungen in der Konfigurationsdatei. Downstream *muss* zuerst kommen, ferner ist altnet für die lokale IPTV Box nicht notwendig.

    Hier eine Config für VLAN 7/8 über eth1 und „Clients“ am eth0:

    quickleave
    phyint eth0 downstream ratelimit 0 threshold 1
    phyint eth1.8 upstream ratelimit 0 threshold 1
    altnet 193.158.34.0/23
    phyint eth1 disabled
    phyint eth1.7 disabled
    phyint eth1.8 disabled
    phyint ppp0 disabled
    phyint lo disabled

    als Belohnung gibt es ein weniger vollgemülltes syslog.

    Eins noch, bitte ggf. daran denken eth1.8 in der Firewall durchzuschalten. Auch ein beliebter fehler. An dieser Stelle die Empfehlung für Firehol von mir.

    Cheers!
    Paul.

  19. Und noch ein Update:

    T-HOME IPTV macht beim Umschalten für die ersten 10 Sekunden Unicast. Wer sich also über lange Umschaltzeiten nach der Umstellung auf den Homebrew-Router wundert, sollte folgendes überprüfen:

    1. Passen die Routen auf eth1.8? Auf meinem Debian System musste ich hin und wieder das eth1.8 Device manuell re-starten (sodass dhclient3 die Konfiguration aktualisiert). Eine Routing-Tabelle für eth1.8 müsste mehr oder weniger so aussehen:

    atomic:~# route -n | egrep eth1.8
    193.158.137.14 93.231.127.254 255.255.255.255 UGH 0 0 0 eth1.8
    217.6.164.45 93.231.127.254 255.255.255.255 UGH 0 0 0 eth1.8
    217.6.164.48 93.231.127.254 255.255.255.248 UG 0 0 0 eth1.8
    217.6.167.128 93.231.127.254 255.255.255.192 UG 0 0 0 eth1.8
    87.140.255.0 93.231.127.254 255.255.255.128 UG 0 0 0 eth1.8
    212.184.168.0 93.231.127.254 255.255.255.0 UG 0 0 0 eth1.8
    193.158.34.0 93.231.127.254 255.255.254.0 UG 0 0 0 eth1.8
    93.231.64.0 0.0.0.0 255.255.192.0 U 0 0 0 eth1.8
    87.141.128.0 93.231.127.254 255.255.128.0 UG 0 0 0 eth1.8

    2. Ist für eth1.8 in der Firewall das Routing und vor allem Masquerading aktiviert? Hier meine funktionierende Konfiguration für igmpproxy 0.1 (final), Firehol und Debian 5 (lenny):

    —- /etc/igmpproxy.conf —-
    quickleave
    phyint eth0 downstream ratelimit 0 threshold 1
    phyint eth1.8 upstream ratelimit 0 threshold 1
    altnet 193.158.34.0/23
    phyint eth1 disabled
    phyint eth1.7 disabled
    phyint ppp0 disabled
    phyint lo disabled
    —- EOF —-

    —- /etc/firehol/firehol.conf —-
    interface lo LOOPBACK
    policy accept

    interface eth0 LAN
    server all accept
    client all accept

    interface eth1.8 IPTV
    server all accept
    client all accept

    interface ppp+ INTERNET
    server ssh accept
    client all accept

    router ROUTER_INTERNET inface eth0 outface ppp+
    masquerade
    client all accept
    route all accept

    router ROUTER_IPTV inface eth0 outface eth1.8
    masquerade
    client all accept
    route all accept
    —- EOF —-

    —- /etc/network/interfaces—-
    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 192.168.1.1
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    preup echo 1 > /proc/sys/net/ipv4/ip_forward
    postup echo 65536 > /proc/sys/net/ipv4/ip_conntrack_max

    auto eth1.7
    iface eth1.7 inet manual

    auto dsl-provider
    iface dsl-provider inet ppp
    provider dsl-provider

    auto eth1.8
    iface eth1.8 inet dhcp

    —- EOF —-

    Multicast Netze via IPTables manuell freizugeben war bei mir mit dieser Konfiguration nicht nötig, wer es allerdings ohne Firehol probieren möchte, dem hilft vielleicht das hier:

    iptables -t nat -A POSTROUTING -o eth1.8 -j MASQUERADE
    iptables -A FORWARD -s 217.0.119.0/24 -i eth1.8 -j ACCEPT
    iptables -A FORWARD -s 193.158.34.0/23 -i eth1.8 -j ACCEPT
    iptables -A FORWARD -s 87.141.147.0/24 -i eth1.8 -j ACCEPT
    iptables -A FORWARD -s 217.6.167.0/24 -i eth1.8 -j ACCEPT

  20. Jetzt hab ich schon einige Stunden an meinem Entertain-Anschluss gebastelt, leider ohne den erhofften Erfolg.. daher hab ich da ein paar Fragen:
    Die meisten werden wohl einen VDSL-Anschluss haben, ich hab einen DSL16+, also ADSL2+. Ich hab schon im Internet gelesen, dass ich die vlan7- u. 8-Geschichten trotzdem brauche und die Netzwerkkarte im „Router“ unterstützt das auch, aber was ist mit dem Modem? Ich hab im Moment eine Fritz!Box SL als Modem über PPPoE am laufen.
    pppd sagt über das Interface eth1.7 gar nichts, über eth1 funktioniert es, ein dhclient auf eth1.8 funktioniert ebenso nicht.
    Ich bin eigentlich ziemlich strikt nach Anleitung vorgegangen, im Log der Firewall konnte ich auch nichts entdecken.. hab ich da einen Denkfehler oder muss ich mir abwärtskompatible VDSL-Hardware besorgen?
    Dankeschön..
    Kai

  21. Hi, bei mir laeuft es nun auch ueber einen vanilla avm 7170 router. War kurz davor eine alternative firmware aufzuspielen, da ich immer nur ein einzelnes IGMP Paket mit dem Inhalt „0 Services available“ erhalten habe. Dummerweise hatte ich es immer ueber wlan probiert .. per ethernet klappt es einwandfrei

  22. Noch ’n Hinweis: Es gibt VDSL-Modems, die sind so lieb und schauen nach dem Einschalten, ob die PADI-Pakete (d.h. die initialen vom pppd) mit oder ohne VLAN-7-Tag ankommen.

    Wenn sie ohne antanzen, dann funktioniert VLAN 7/8 nicht mehr.
    Also nach dem Umstellen auf VLANs vorsichtshalber erstmal das Modem powercyceln.

Hinterlasse einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.